Fixing Duplicator Timeout Errors

Discussion in 'WordPress Guides' started by Chuck, Nov 14, 2017.

  1. Chuck

    Chuck Administrator
    Staff Member Grep What?

    Joined:
    May 17, 2017
    Messages:
    39
    Likes Received:
    0
    Duplicator is IO heavy and the lite version does not offer any way to control or limit its IO use. The first thing you will want to check is if you are hitting IO limits on your account which can cause an error like this:


    In your cPanel scroll down until you see the icon called "CPU And Concurrent Connection Use". The following page will let you know right off whether you have hit a limit.


    Click on details and the next page will give you details for your resource limits and shows faults in light blue. If you mouse over a fault it will show you the time the fault occurred. If this matches the time that your Duplicator run failed you have found the culprit :)

    Contact our support requesting an increase in your IO limit.

    There are two more possibilities I have seen from time to time:

    1. CloudFlare can interfere (524 error), so if you use that I suggest you deactivate it for the Duplicator run. In DNS settings turn the orange cloud grey for your main domain a-record(s).

    2. php max_execution_time: You can increase this in your cPanel account by locating Select PHP Version:


    On the following page look at top right corner and click "Switch To PHP Options". Locate max_execution_time and change it to an amount greater then the time expected for duplicator to finish and click "apply" then "save". Time is in seconds:


    These things will solve any Duplicator timeout issues in most cases.
     
    #1 Chuck, Nov 14, 2017
    Last edited: Nov 16, 2017

Share This Page